Back to overview
Downtime

E-Sign signature service outage and high latency

Mar 05, 2026 at 07:00pm UTC
Affected services
GoFirmex Sign Portal
Sign e-sign Service

Resolved
Mar 05, 2026 at 10:43pm UTC

The services have now returned to normal operation. While we are still observing slightly higher latency than usual in some identity validation requests related to Gobierno Digital and the Servicio de Registro Civil e Identificación (primarily Clave Única), response times are currently within an acceptable operational range and the signing process is functioning normally.

We will continue monitoring the situation to ensure full stability.

Updated
Mar 05, 2026 at 07:48pm UTC

Our investigation indicates that the services most affected are the identity validation services dependent on Gobierno Digital and the Servicio de Registro Civil e Identificación, primarily the Clave Única authentication service. These services are currently experiencing high latency, which is impacting the entire signing workflow and causing delays during the identity verification stage of the signature process.

The team is actively monitoring the situation and continuing to investigate the root cause. Further updates will be provided as more information becomes available.

Created
Mar 05, 2026 at 07:00pm UTC

We are currently experiencing an incident affecting the e-Sign signature service. The service is either unavailable or responding to requests with extremely high latency. The issue has already been reported and the e-Sign team is actively investigating the situation. We will provide further updates as soon as more information becomes available.