Back to overview
Degraded

Google Cloud Network Intermitence

Feb 25, 2026 at 03:15pm UTC
Affected services
GoFirmex Sign Portal
GoFirmex Enterprise Portal
Sign Sovos Service
Sign e-sign Service

Resolved
Feb 25, 2026 at 04:30pm UTC

The issue has now been resolved by Google Cloud. Connectivity has been fully restored, and all portals are currently operating normally without interruptions. Google is actively investigating the root cause of the incident. We will continue monitoring to ensure stability.

Created
Feb 25, 2026 at 03:15pm UTC

We are currently experiencing intermittent connectivity issues affecting some Google Cloud network services. This instability is impacting access to our portals, causing temporary timeouts and degraded performance. We are actively monitoring the situation and working with our infrastructure provider to restore full stability as soon as possible.