Back to overview
Degraded

Intermittent identity validation services

Jan 20, 2026 at 04:00pm UTC
Affected services
GoFirmex Sign Portal
Sign Sovos Service
Sign e-sign Service

Resolved
Jan 20, 2026 at 07:00pm UTC

The intermittency affecting the identity validation services is progressively decreasing, and the service is returning to normal operation.
The mitigation actions implemented have reduced response times and the retry queue.
We continue to monitor the service to ensure full stability.

Created
Jan 20, 2026 at 04:00pm UTC

The identity validation services used in the signing process are experiencing intermittent issues, resulting in delays and reduced performance.
Our team is implementing mitigation actions to reduce the retry queue, while the identity service provider is reviewing the reported cases.
The situation will continue to be monitored until full service normalization is achieved.