Back to overview
Downtime
CUE and SRCI services down
Jan 21, 2026 at 09:20pm UTC
Affected services
GoFirmex Sign Portal
Sign Sovos Service
Sign e-sign Service
Resolved
Jan 22, 2026 at 01:00am UTC
Identity services are now operating normally
Affected services
Updated
Jan 21, 2026 at 09:50pm UTC
Response times for the identity services are gradually returning to normal.
The service remains under active monitoring.
Affected services
Created
Jan 21, 2026 at 09:20pm UTC
There was an outage of the identity services. The issue has been reported, and we are awaiting a solution from the responsible entity.
Affected services